Apples nyeste utgaver av AirPort Time Capsule og AirPort Extreme er berørt av Heartbleed-sårbarheten. En sikkerhetsoppdatering er nå klar.

Apple berørt av Heartbleed likevel

Men selskapet har sine tidligere ord i behold.

Det er to store IT-leverandører som man i særlig grad har framstått som lite berørt av Heartbleed-sårbarheten – Microsoft og Apple. Siden OpenSSL er lite brukt sammen med Windows, er det ikke så overraskende at Microsoft har sluppet unna. Og uttalelser fra Apple har tydet på at også dette selskapet har unngått å bli berørt.

Nå viser det seg at det siste nok er en sannhet med modifikasjoner, selv om Apple egentlig har spilt med åpne kort.

I går kom Apple nemlig med en sikkerhetsoppdatering til de utgavene av basestasjonene AirPort Extreme og AirPort Time Capsule som støtter 802.11ac. Årsaken er nettopp Heartbleed-sårbarheten i OpenSSL, som i dette konkrete tilfellet gir en angriper i et privilegert nettverkstilgang mulighet til å få tilgang til innhold i enhetens minne.

Sårbarheten kan kun utnyttes dersom funksjonene Back to My Mac eller Send Diagnostics er aktivert. Oppdateringen kan installeres ved hjelp av AirPort-verktøy som er tilgjengelige for OS X og iOS.

Når det gjelder Apples tidligere uttalelser om Heartbleed, har de kun dreid seg om OS X, iOS og sentrale webtjenester. I AirPort-produktene benytter Apple andre operativsystemer, i alle fall VxWorks og NetBSD.

Til toppen