Java på Mac er ikke helt uproblematisk når Apple fra tid til annen blokkerer kjøringen helt uten forvarsel.

Apple blokkerer Java på nytt

Brukerne ble ikke informert.

Mange brukere av Apples OS X 10.6 Snow Leopard og nyere har det siste døgnet opplevd problemer fordi Apple nok en gang har stengt muligheten til å kjøre dagens utgaver av Java på systemet.

Det er XProtect-systemet i OS X som har sørget for blokkering ved at en oppdatert hviteliste krever at Java må ha versjonsnummer 1.7.12.x eller høyere for å kjøre. Den nyeste offisielle versjonen av Java har versjonsnummer 1.7.11.

Apple har gjort dette fordi Java 7 update 11, som 1.7.11-versjonen også kalles, inneholder alvorlige sårbarheter. Selskapet gjorde det samme i første halvdel av januar, da minimumsversjonen ble oppgitt til å være 1.7.0_10-b19, mens den nyeste versjonen tilgjengelig var 1.7.0_10-b18.

Dette hadde ikke vært noe problem, dersom det hadde vært en enkel og velkjent måte for brukerne å overstyre sikkerhetsfunksjonen. Men diskusjonene blant annet her og her forteller at dette skaper problemer for brukere av Java-baserte klientløsninger.

Også norske brukere opplever slike problemer.

– Det er helt håpløst at de ikke informerer brukerne. Folk blir dermed sittende å streve med dette. Laster ned og installerer på nytt mange ganger uten å få det til å fungere, skriver en leser til digi.no. Han forteller videre at det ikke har vært noe hjelp å få hos banken, som bare skal ha oppfordret ham til å installere siste versjon av Java.

Mulige løsninger

Det skal være to potensielle løsninger på problemet. Det enkleste skal være å bruke 64-bits utgaven av Firefox. Angivelig skal kjøring av Java i Firefox ikke være berørt av XProtect-blokkeringen.

En annen mulighet er å installere en tidlig versjon av Java Runtime Environment (JRE) 7 update 12. Men dette er en uferdig versjon som kan forårsake nye problemer.

Digi.no har ikke testet metodene og kan derfor ikke gå god for noen av dem.

    Les også:

Til toppen