Firefox skal varsle om flere utdaterte plugins

Flash-advarselen var bare første skritt på veien mot bedre sikkerhet.

Mozilla vil gå enda lenger i å advare brukerne mot utdaterte og potensielt farlige nettleserplugins. Tidligere denne måneden, i forbindelse med utgivelsen av Firefox 3.5.3 og 3.0.14, ble brukere med utdatert Flash Player-plugin advart om nettopp dette.

Men Mozilla har videre planer.

Mozillas Christopher Blizzard skrev tidligere i september litt mer informasjon om dette i en kommentar til dette blogginnlegget.

Først, allerede i løpet av denne måneden, skal Mozilla gi ut en vanlig webside hvor nettleserbrukere kan sjekke tilstanden til nettleserens plugins. Det er ikke oppgitt om denne siden kun vil være til nytte for Firefox-brukere.

Firefox 3.6, som trolig kommer i fjerde kvartal i år, skal se etter nye versjoner av plugins på samme måte som den ser etter nye versjoner av nettleseren selv eller nettleserutvidelsene. Hvis den oppdager at en plugin er utdatert, blir man sendt til den nevnte siden.

Det jobbes også med å gjøre installasjonen av plugins enklere, blant annet med Adobes Express Install-system, som gjør det mulig å oppdatere Flash Player fra pluginen uten å bruke et separat installasjonsprogram.

Sårbarheter i nettleserplugins er populære blant kriminelle fordi mange brukere benytter utdaterte plugins, i tillegg til at sårbarheter i slike plugins ofte er uavhengige av operativsystemet de kjøres på.

    Les også:

Til toppen