Oppgrader til Opera 9 - for sikkerhets skyld

En ny sårbarhet i Opera er blitt offentliggjort. Den finnes ikke i den nyeste utgaven.

Brukere av eldre utgaver av Opera bør snarest oppgradere til versjon 9, som ble lansert tidligere denne uken. I de fleste eldre utgaver av nettleseren finnes det et sikkerhetshull knyttet til behandling av JPEG-filer.

Hvis svært store verdier for høyde og bredde spesifiseres i visse felter i en JPEG-fil, skal dette fører til en heltalls overflytsfeil som får Opera til å sette av utilstrekkelig minne for bildet. Dette vil ifølge sikkerhetsselskapet VigilantMinds føre til en overflytsfeil i en buffer når bildet lastes inn i minnet. Denne feilen kan utnyttes til å kjøre vilkårlig kode.

Opera 9 kan lastes ned til flere operativsystemer fra denne siden.

Til toppen