Tetter sårbarheter i Firefox og Thunderbird

Mozilla har utgitt nye utgaver av både Firefox og Thunderbird for å tette en serie sårbarheter i produktene.

Både Firefox og Thundebird er nå utgitt i versjon 1.5.0.4 etter at Mozilla på torsdag publisert oppdaterte utgaver av disse produktene. Dette delvis gjort for å tette flere til dels alvorlige sikkerhetshull.

I Firefox regnes flere av hullene som kritiske. Det dreier seg blant annet om overflytsfeil som ofte kan utnyttes til å kjøre vilkårlig kode.

I Thunderbird regnes én av sårbarhetene som kritisk. Denne er knyttet til prosesseringen av store VCard som inneholder. ugyldige base64-tegn.

Det skal ha blitt gjort forbedringer i stabiliteten til begge produktene. I tillegg skal Thunderbird ha fått Universal Binary Support for Mac OS X, det vil si naturlig støtte for Macintosh med Intel Core-prosessorer.

En oversikt over de tettede sikkerhetshullene i produktene finnes på denne siden.

Firefox og Thunderbird med versjonsnummer 1.5 eller nyere vil relativt raskt laste ned oppdateringene selv. Men dette kan framskyndes ved be programmet se etter nye oppdateringer. Dette kan gjøres under Hjelp-menyen.

Til toppen