Alvorlig sårbarhet patchet i OpenOffice.org

En sårbarhet, som sikkerhetsselskapet Secunia anser som meget kritisk, er blitt oppdaget i eldre utgaver av OpenOffice.org. Versjon 2.1 er ikke berørt.

Sårbarheten skal gjøre potensielt mulig for ondsinnede å kompromittere en brukers system. Den skyldes en heltalls overflytsfeil i komponenten for WMF/EMF-filer og kan utnyttes ved å lokke brukere til å åpne en spesielt utformet fil. Vellykket utnyttelse åpner for kjøring av vilkårlig kode.

Brukere av OpenOffice.org 2.x bør oppgradere til versjon 2.1. Brukere av versjon 1.x bør enten oppgradere til versjon 2.1 eller til versjon 1.1.5. I det siste tilfellet må det i tillegg lastes ned og installeres oppdaterte bibliotekfiler. Disse er tilgjengelige her.

Til toppen