nettverk og infrastruktur
Disse dokumentene har definert internett i 50 år
Den første RFC-en ble publisert allerede i april 1969.
Det skjedde flere store, teknologiske begivenheter i 1969. Den første månelandingen er nok den som er mest kjent. Men også den virkelige oppstarten av ARPANET, forløperen til dagens internett, skjedde på høsten dette året. Den fikk nok ikke like stor oppmerksomhet av samtiden som månelandingen, selv om den noen tiår senere har vist seg å ha minst like stor betydning.
Forskere ved en rekke institusjoner i USA bidro til dette, og i forbindelse med disse forberedelsene publiserte forskeren Steve Crocker et dokument for å dokumentere hvordan pakker kunne sendes mellom datamaskiner i det kommende ARPANET.
«Request for comments»
Dokumentet var rettet til Network Working Group, en gruppe innen daværende ARPA som Crocker hadde organisert. Dette var forløperen til standardiseringsorganisasjonen Internet Engineering Task Force (IETF), som i dag har ansvaret for RFC-ene.
I toppen av dokumentet står teksten «Request for comments». Lite visste Crocker at dette skulle bli det første av en svært lang rekke av slike RFC-er, som i begynnelsen var nettopp forespørsler etter kommentarer om ideer og forslag. I dag er mange RFC-er viktige internettstandarder, inkludert HTTP 1.0 og TLS 1.3, for å nevne noen.
– Jeg hadde aldri drømt at disse notatene til slutt ville bli distribuert gjennom det samme mediet som vi diskuterte i disse notatene. Snakk om trollmannens læregutt!, skriver Crocker i en historisk gjennomgang som selvfølgelig er utformet som en typisk RFC.
Over 8500
– Målet var å starte en samtale framfor skape en arkivoppføring for en standard eller beste praksis. Dette målet har endret seg over tid, etter hvert som formaliteten ved publikasjonsprosessen har utviklet seg, og at fellesskapet som konsumerer materialet har vokst, skriver Heather Flanagan, dagens RFC-redaktør.
– I dag har det blitt publisert mer enn 8500 RFC-er, som spenner fra informasjon om beste praksis, eksperimentelle protokoller, informasjonsmateriell og selvfølgelig internettstandarder, fortsetter hun.
«Avian Carriers»
En og annen spøk har det også blitt plass til i RFC-ene. Den mest kjente er nok RFC 1149, med tittelen «A Standard for the Transmission of IP Datagrams on Avian Carriers». Den ble utgitt 1. april 1990.
Blant annet lyder teksten, oversatt: «Flere typer av tjenester kan tilbys med en prioritert hakkeorden. En ytterligere egenskap er innebygd detektering og utrydding av mark. Fordi IP bare garanterer leveranse etter beste evne, kan tap av en bærer bli tolerert. Med tiden er bærerne selvregenererende.»
RFC-en har blitt oppdatert to ganger, med RFC 2549 «IP over Avian Carriers with Quality of Service» den 1. april 1999 og RFC 6214 «Adaptation of RFC 1149 for IPv6» den 1. april 2011.
Tegningen nedenfor er hentet fra RFC 2549 og bør gi et godt hint om hva bæreren som brukes i disse RFC-ene egentlig er.
__ _____/-----\ / o\ <____ _____\_/ >-- +-----+ \ / /______/ | 10g | /|:||/ +-----+ /____/| | 10g | | +-----+ .. X =============================== ^ | =========
Les også: Brevdue vant over bredbånd